Forums

  • Black screen when built I made a app with vuforia.It runs normal in Unity Editor but when I built and run it shows a black screen and do not open camera.I did everything step by step but it did not work.Is there anybody know how to fix it.
  • Combine Image Target with Ground Plane I'm trying to "combine" image target and ground plane detection. I want to have a button on the image target which enables a ground plane stage. I dont really know what the best approach is. Maybe something with having ground plane activated (but with the plane indicator deactivated) from the start, and then the user taps the button instantiated by the image target, which then shows the plane indicator. Then the user taps again and the plane stage is instantiated.

    or better: the...

    Combine Image Target with Ground Plane
  • [Help] How would I do raycasthit using GvrLaserPointer. I am trying to do raycasthit from my daydream controller model in my scene in order to get transform.position where the raycast hit collider. I already tried using ray from controller transform toward direction (gvrcontroller.ori * vector3.forward). My...
  • Splited app with obb : Target Image not working I see that many people had this problem over time, even I did. I used to have a script that made the game work just fine, until now. I needed to upgrade Vuforia because of the black screen bug on IOS, I'm now using Vuforia 8.0.10 and it's working fine on IOS. BUT, it doesn't work anymore on android.

    I obviously searched the answer but nobody seemed to have this problem on Vuforia 8.0.10 and of course, I tried the...

    Splited app with obb : Target Image not working
  • First Steps – Unity3D – Version 2018.3.10f1 Personal Hello there, I am having this issue while running my application. Does someone know how to have that fixed? I am following these steps: https://docs.unity3d.com/Manual/vuforia_get_started_project_setup.html I am using Windows 10. Unable to start Obje...
  • MRTK settings missing Hey, i hope i'm right here.

    First of all, i'm complete new to this all (since yesterday to be precise).
    I'm trying to build a hologram for the hololens. I installed everything: Visual Studio 2017 - Unity and Universal Windows Plattform, Unity 2018 - with .NET.
    However, when i import the MRTKv2 package into unity, i'm missing some important settings. I already deleted unity and reinstalled it.

    For example, i'm missing the "Apply Mixed Reality Project Settings".

    I hope you can help me. Thanks
  • he type or namespace name ‘SpatialTracking’ does not exist in the namespace ‘UnityEngine’ (are you m I am using latest unity 2018.3.10f1 and I have the following error in google SDK AR CORE. There is similar issue on the internet, all say that updating unity would fix the issue, but since I have the latest option, I wanted to know if there is a fix ? ...
  • Mira SDK – how to use gyroscope (compass?) info to control user lookat? I unsuccessfully tried to use Mira SDK in order to have user always look at the same part of my virtual scene when user looks (say) toward the geographic North. My goal is to make sure that always the same part of my virtual scene is observed by the us...
  • Scripting Gyroscope Drift Hello, I am developing an AR application. In this application I use a "headtracking" that I use on the camera, it allows me to be in a 360 ° environment. As I saw on other thread some of you also have a problem of "drift". The pr...
  • ARKit ARReferenceObject Issues when using Apples Scanner with usdz-Model as Refererence Hey there, I was provided with a arobject file which was created from an architectural modell. The goal is to replace the real world model with an interactive one using ARKit and the object tracking functionality. We scanned the model using Apples giv...
  • Menu created using TextMeshPro not visible in HoloLens emulator after building. I have created a menu using TextMeshPro and it is not visible after building the UWP app and deploying it on HoloLens emulator. I have previously developed IoT apps and the settings are as they should be with .NET set to 4.x. Any ideas?
  • Using Daydream Elements Arm Models with Third Person Character/Mecanim I've been working on an adventure game, in which I have a weapon that can be equipped to be welded by my GvrControllerPointer. I also have an avatar character that uses animations from the Unity Standard Assets, so I can walk/run/turn and see my body and feet move.

    Now, I want to put the two together, and I'm not sure where to start. I want the arm of the character model to move and be controlled by my GvrControllerPointer, just like the Daydream Elements swing arm.

    Any advice would be...

    Using Daydream Elements Arm Models with Third Person Character/Mecanim
  • World positions of left/right eye Hi,

    I need to get the precise world positions of left and right eye in Unity 5.1s native VR support (read-only). Is there an API call for this, seeing how the VR Camera rig is now constructed and handled by Unity behind the scenes? It's easy if one uses the OVRCameraRig Prefab from the Oculus Tools for Unity, but I prefer to use Unity's native VR Camera for compatibility reasons.

    I am aware of "InputTracking.GetLocalPosition(VRNode.RightEye)", but this gets the "position of node local to...

    World positions of left/right eye
  • Mock HMD returns zero for left/right eye I have two cameras in my scene (one set up to render different stuff in each eye).
    However I can't get the eye offsets in my "OnPreRender" method called per eye.

    InputTracking.GetLocalPosition(XRNode.LeftEye) returns a Vector3.Zero value.
    I'm using a Mock HMD. Is this a bug in the mock hmd? Am I missing something?

    Win10, x64, Unity3D 2018.3.9
  • Unreliable 360 video playback on Oculus Go Hey All,

    I'm building a project where I have 4 videos (360, 4K, H.265)
    Each are lined up to play (using a skybox & video player) in their own scene, a script tells them to play and a coroutine counts the seconds before telling Unity to move onto the next scene. Pretty simple.

    Within the Unity editor the project runs flawlessly. (I do have to swap the video to H.264 versions to preview, as H.265 isn't yet supported, then swap them back to H.265 to export for Android). I use H.265 to try to...

    Unreliable 360 video playback on Oculus Go