Forums

  • Asset Bundle Not Working in Build (Hp Headset) Hi, I have a problem. In the build, the UWP asset bundles are not loaded. Only the LoadFromFile and LoadFromFileAsync methods work in the build, but this methods crashed Unity in project. At the same time, other methods are loaded completely in the pro...
  • 9D cinema 9d egg chairs Hi, I need to know how 9D egg chair works so i can make games for my client , he has one, and he asked me if i can make a game for him, it should be the same as for VR but the thing that i am not sure is how the sound, the chair movements,the air pre...
  • Water environment works in ARKit? Hello, complete beginner here but have eeked out a few demos so far. I was trying to load the Water plane prefab from Environments in Standard Assets, but the water/model never showed up when I ran the build on my iPhone. I am familiar with how to attach it to the hitcube, so don't think it is that, but im definitely missing something. I saw that they said the water does not work in VR, so is it possible that it won't work in AR as well? Thanks in advance.
  • Single Pass Stereo Rendering on Vive Not Working https://docs.unity3d.com/Manual/SinglePassStereoRendering.html

    I'm trying to make single pass stereo work with vrtk in a vive headset. I am running on a GeForce GTX 1080 in Unity 2017. The display in the headset looks very wrong, because I'm getting a total of four images in the final output. (first image) In unity, I'm getting an off oval shape in the center I'm unsure is correct. (second image)

    Something about SteamVR is doing this. I get correct output when I make a...

    Single Pass Stereo Rendering on Vive Not Working
  • Adding more image to detect but not updating application Arkit. As far as I know, we can add image references and groups programmatically. After restarting session, Arkit will detect images. I want to make a controller when the app opens and reads images to detect. When there is a new image it should download it to...
  • Tiny camera preview sitting in the inspector. Please go away! (LRP and Oculus – 2018.2.1f1) This might be a simple switch which I can't find.

    Every time I run the game in the Editor, if there's an object selected which includes a material, a tiny little 1cm x 1cm camera preview window appears at the bottom left of the inspector. It's too small to be of any use and it's accompanied by a blizzard of errors:
    Cannot change renderViewportScale while cameras are rendering!
    UnityEngine.GUIUtility:processEvent(Int32, IntPtr)​
    As you might imagine this cripples Editor...

    Tiny camera preview sitting in the inspector. Please go away! (LRP and Oculus - 2018.2.1f1)
  • Oculus Go: body transform? The Oculus Go SDK, under the hood, calculates a position for the controller based on some IK model of the body, shoulder, and arm, which updates in mysterious ways. For example, if I turn my head quickly or by small amounts, the virtual arm stays put, but if I turn more slowly or by a greater amount, then the arm rotates in a way that indicates the invisible body is rotating too.

    I'd like to get that body transform, so I can draw a bit of a body, an opposite arm, etc.

    Does anybody know...

    Oculus Go: body transform?
  • VRTK beginning to show it’s age with latest SteamVR update? Now that TheStoneFox will no longer be maintaining the VRTK branch, I fear that SteamVR must take on the pivotal role of ensuring seamless backwards compatibility if VRTK is to survive.

    But it appears to me that in some situations many people are reporting controllers not working in Unity since the latest SteamVR update, I too noticed controller problems in the last and current betas where if Vive Trackers are turned on they will invoke options for Legacy Bindings menus when the game...

    VRTK beginning to show it's age with latest SteamVR update?
  • LEAP MOTION – dynamically changing tracking orientation C# Hi,

    I'm working on a project where hands are tracked from both sides of the device (only one side at a time). I'm having trouble with accessing the config settings to reverse the orientation from a C# script.

    Code (CSharp):
    1. using System.Collections;
    2. using System.Collections.Generic;
    3. using UnityEngine;
    4. using Leap.Unity;
    5. using Leap;
    6.  
    7. public class LeapConfigTester : MonoBehaviour {
    8.  
    9.     public LeapServiceProvider leapProvider;
    10.     public Controller leapController;
    11.     public Config leapConfig;...
    LEAP MOTION - dynamically changing tracking orientation C#
  • Platform Dependent Compilation for Hololens Does anyone know what the platform dependent compilation preprocessor directive is for Hololens?
  • How Object tracking is done in Arkit-2 using Unity? Hi I was trying to Augment on Objects using Arkit 2 Object tracking.I opened the UnityARObjectAnchor.unity scene.Arkit2 contains sample objects in GameObject-GenerateObjectAnchorWipesBottle to test.When I build the app it just freezes after opening the...
  • Cardboard VR Tutorial Hi For those that have been frustrated trying to develop a simple VR app for cardboard and are having issues with Android SDK builds on new editions of Unity, i have put together a quick tutorial that demonstrates how to make a small but effective ap...
  • How to stop generating and or destroy all planes Just wanted to drop this knowledge in a public place, because I lost many hours/days trying to figure it out. With the Unity ARKit plugin, there is no clear or obvious way to reset planes or stop planes from continuing to generate. Here's some basic knowledge about what's going on.

    There are two separate versions of the "planes" being generated as your user is scanning the world in an ARKit/Unity app. There are the "anchors" which seem to be stored on the native side itself, independent of...

    How to stop generating and or destroy all planes
  • Event System – Raycast LayerMask With the event system active the reticle always shows. I am unable to find where I can add a LayerMask to the raycast? thank you
  • Compile Error Hello!

    I've already had a RA project with unity + vuforia, in Unity 2017, but I decided to update the unity for version 2018.2.1f1 , and after that some problems are happening, when opening and trying to compile that same project, the following error appeared:

    "error CS1704: An assembly with the same name `Vuforia.UnityExtensions.Editor' has already been imported. Consider removing one of the references or sign the assembly
    C:/Program...

    Compile Error