Forums

  • Fade works on screen but not in headset Hey all...
    I have VR app that will load one video, fades out loads new video fades back in. This all works fine on the monitor. However, in my Oculus headset this is not working. I've tested wondering if it was because of the placement of the panel but, but no matter which direction the headset is pointing, the screen fades, but the headset does mot.

    The fade is based on modifying the alpha of a UI panel.

    Any suggestions on how to correct this?

    Thanks so much!
  • (bug report) ARM64 breaks VR for Gear VR Didn't see a board for ARM64 (experimental) build target.

    Unity 2017.1.7
    .NET 4
    IL2CPP
    XR enabled
    simple scene
    Galaxy Note5 Gear VR device

    What I did:
    Enabled ARM64 target build architecture (for Android)

    What I got:
    Device does not enter VR mode.

    Confirmed that disabling ARM64 and leaving everything else the same resolves issue.
  • Non-VR App with “Toggle VR” button ? Hi everyone !

    I am currently developing a software that reproduces an existing WebVR app which basically consists in a 360 scene viewer.
    The WebVR app has a classic browser view in which we can click and drag to rotate the camera and a "toggle VR" button which enables the view in a MR device if used in Edge.
    In my app I already implemented the basic view, but I can't find a way to create the same kind of "toggle VR" button for MR headsets, is there a way to do so in Unity ? I already have...

    Non-VR App with "Toggle VR" button ?
  • Inaccurate measurments by ruler / measurement app in unity ARKit I'm working on an application for room measurement, a ruler of sorts, using the ARKit in Unity3D. For this I am using raycasts to place objects (spheres), against the wall, and calculate the distance between those objects by getting the position of recognized walls, which the ARKit generates.

    The problems I have:

    • My placed objects are mostly a bit to far away from those ARKit walls.
    • Those objects are floating away when I move. So the measurements are not that precise.
    • Extra...

    Inaccurate measurments by ruler / measurement app in unity ARKit
  • HoloLens shared tap-to-place issues Hello, the problem I'm having is a little complicated as I tried different ways of solving it ending up with different issues, so I'll try to break this down.
    Using Unity 2017.4.1f1.

    1. Mixed Reality Toolkit (Example)
    I implemented this specific package containing the standard toolkit and a few examples, then proceeded to open the SharingTest scene. It had a missing script which I replaced with...

    HoloLens shared tap-to-place issues
  • Spawning Prefabs on free Plane-Position AR Hey Guys, i am new to Unity. I want to create a AR-APP in which it is possible to create prefabs. This worked for me. My problem now is that I want that the prefabs only spawn when the Space on the Plane is free, but the Prefabs are spawning everywher...
  • Unable to submit an APK file to Play store with com.google.ar.core error Hi all, I compiled my app with vuforia support and tried to upload it to the store. However, I encounter this error. The ARCore dependency minimum version code com.google.ar.core.min_apk_version is missing from the AndroidManifest.xml file although ...
  • Any ideas for a VR navigation package? Hi everyone,

    I'm going to implement a spindle control system, in Unity, for scene navigation in VR (something like that used in Quill).

    Since I'm already doing that, it seems that prototyped other control schemes wouldn't be too much extra work. So, if you have an idea that you wanted to explore but don't have time to script up then let me know - I'm happy to mock it up and, if there are at least a couple of ideas,...

    Any ideas for a VR navigation package?
  • Resonance Audio, possible Skybox issue, or something else moved here as it seems more related: https://forum.unity.com/threads/res...-high-fidelity-spatial-audio-at-scale.503347/
  • Cardboard VR distortion Hi All,

    Running ARCore's sample scenes works perfectly on a phone (Pixel 2). However, upon checking off 'VR Support Enabled' and putting it into a headset, things look wonky.

    Enabling that checkbox does split the camera view into two. ARCore only uses one camera, so it must be duplicating the view. I notice I can get a better image when adjusting the lens on my cardboard headset. I've heard this could be due to ARCore using a different FOV than Cardboard.

    Does anyone have any insights...

    Cardboard VR distortion
  • ‘Virtual buttons’ for non Vuforia AR apps All the examples showing virtual buttons in Ar are using Vuforia's solution. But I am not using Vuforia and need a virtual button solution in AR.


    What is the best solution? Should I import the Vuforia framework just for the button?
  • ARFoundation + ARKitRemote? Hello everybody, Is there a way to get the ARKitRemote to work with the ARFoundation toolkit? I’ve got the remote working with the older examples (including that compression workaround posted here), but I’m not sure if that’s the right way to go with ...
  • Stereoscopic rendering support I've read the manual on How to do Stereoscopic Rendering but for the life of me I cannot figure out how to turn on stereoscopic rendering in Unity. The DirectX sample that is referenced does not use or require any aspect of Unity as far as I could see. I got it to compile and run, but it is a standalone C++ Windows app, not a Unity-based PC app. Also, in my Player Settings, I do not see any checkbox for "Stereoscopic...

    Stereoscopic rendering support
  • Unable to connect Unity and ARKit remote I get the following error. 2018-07-09 20:43:26.641523+0300 remote NSURLConnection finished with error - code -1009 Does any one know how to fix?
  • ARKit Remote workflow issues There are 2 issues slowing me down right now when developing:

    1. There is about a 4 second time lag on the video that hits the editor from the ARKit Remote. It looks like in the demo it's much snappier, but in the comments others are having the same lag issue as I am. Is there any way to troubleshoot this?
    2. I have to select my iphone from the connected player dropdown every single time I press play. I would love it if it...

    ARKit Remote workflow issues