Forums

  • GVR SDK for Unity v1.130.1 I am developing applications with MirageSolo using Unity 2017.4.2 f 2.
    SDK uses GoogleVRForUnity_1.130.1.
    I'd like to acquire the height of the floor now but it will not work.
    As an execution result, bool: True float: -1.6 is returned.
    Is this my problem? Or is it a problem with SDK?
    Please tell me.

    Code (CSharp):
    1. using System.Collections;
    2. using System.Collections.Generic;
    3. using UnityEngine;
    4.  
    5. public class Test : MonoBehaviour {
    6.  
    7.     public TextMesh text;
    8.     float height;
    9.  
    10.     //...


    GVR SDK for Unity v1.130.1
  • App works fine through instant preview but has major graphical errors in build. Obviously whatever the camera is recording isn't being rendered in any way. Clear flags are set to Depth Only by ARCore when the app starts so I'm not sure why it looks like clear flags are set to Don't Clear. The next most obvious thing is the screen is mirrored vertically! The scene in the screenshot is literally the vanilla HelloAR scene that comes with ARCore. I haven't made any changes. I'm almost positive the problem isn't the phone (Pixel 2.) It's brand new and I tried some ARCore...

    App works fine through instant preview but has major graphical errors in build.
  • Detect collision on a real world object Hello all, I have created Holo objects (cubes,etc.) in Unity3D. I have used spatial mapping settings for the holo objects to get occluded in the real-world environment. But, when I tap and move the object, the object passes through the real world obje...
  • [In Progress] True Clouds – volumetric clouds for Mobiles & PC. VR? True Clouds is a plugin for super-efficient rendering volumetric artist-driven clouds, even on mobile devices. Asset Store | Documentation | Android Demo | PC Demo View attachment 263594
  • How to visualize ground planes? In the Unity ARKit plugin, you can get data about tracking points and surfaces. This allows you to create debug visualizations or even show the player where surfaces are detected. Is it possible to visualize a ground plane with Vuforia? With a Plan...
  • Best way for a steering lever Hi out there! Long version: I am currently implementing a steering lever into Unity, to control a swivelling Gun. Since the lever should allow for axis movement in X and Z and should be grabbable with Motion Controllers. Currently, I am solving it wi...
  • Steam VR Unity assign ControllerManager Objects at runtime Good Morning,

    Sorry, this is a very specific and potentially long and confusing question but I'm hoping someone can help me.

    I am using 2 VIVE Trackers to create a 3D Audio AR networked VOIP application (basically have 1 tracker in the physical space as a networked player and the other tracker on the users head as I don't want to use the HMD) inside unity using UNET and the Steam VR plugin.

    So when I create the server and connect clients I am instantiating a Prefab object with a Tracked...

    Steam VR Unity assign ControllerManager Objects at runtime
  • unity2017.3.0f3 with vuforia for ios build failed. When build ios version, error occured in xcode which msg is "can't open file for writing :xxxxxx, errno=21 for architecture arm64"
    Any suggestions?
  • AR on HoloLens… Okay, this time I tried /qian256/HoloLensARToolKit on the streaming on-device emulator and ended up with a white square, a multicolored cube, and three lines of static text, all floating in arbitrary positions. It wouldn't even compile in Visual Studio for some reason.
    Are year-old demos even supposed to work? What am I doing wrong? Is there some sort of official archive of things that actually do work on the most recent version of Unity/VisualStudio, or is everything supposed to be trial...

    AR on HoloLens...
  • ShadowDrawer broken – anyone have a fix? We've been relying on the ShadowDrawer shader to cast shadows from CG elements onto live action in AR through Vuforia. It's been working perfectly.

    Apparently, a there's a call to a routine in the shader that's been deprecated for a while but has now been removed from 2018.

    this is the broken line:

    half atten = LIGHT_ATTENUATION(IN);

    Supposedly LIGHT_ATTENUATION has been replaced with UNITY_LIGHT_ATENUATION but it's not a direct swap.

    We need 2018 to patch a vuforia/iOS 11.3...

    ShadowDrawer broken - anyone have a fix?
  • Yet another camera scaling thingy… 🙂 Hi there :)

    Long Version:
    I am currently building an awesome mech simulator for VR, yet the camera is definitly too big. Since I don't want to scale the world (physics...), I am left with scaling the camera.
    The only fun thing is, that no matter what I parent the Cam to and no matter if I change the scale on either the Cam or the Parent, the Camera just stays the "same size", which is troublesome, since I dont want to enable the player to look through the roof of the mech... alll the time...

    Yet another camera scaling thingy... :)
  • Trying to get Google Daydream controller laser to pass through a collider to hit another collider Hi, I am currently trying to find a way to get my controller laser to pass through a wall collider to reach a ball behind it. The ball has it's own collider and works without the wall, but I need the wall there to contain the balls. I have tried putting the wall and laser on different layers but that does not seem to work.

    The wall is there because it is part of a container that contains the balls, but the player is outside and needs to select certain balls once they stop bouncing.

    Does...

    Trying to get Google Daydream controller laser to pass through a collider to hit another collider
  • Oculus screen goes black I occasionally have a problem where soon after running (in the editor) the display on my Oculus Rift goes black, and the following is output to the console: InitD3D11RenderColorSurface: VRDevice said it created a texture, but the texture is NULL. VR p...
  • Xiaomi Mi A1 Hi!
    I'm using Unity 2018.1.0f and Vuforia 7.1.34. If I make a build and run it on Xiaomi Mi A1, the fps of the camera is really low. Even if I build a sample project or a completely empty project the FPS is very low, the video plays back normally, though.
  • Vrtk controller objects are destroyed on run. Hello i experienced something really strange i am driving myself crazy trying to fix it. Suddenly from what seem to be nowhere the ability to access the vive controllers was lost, they dissiperar on runtime, not just the mesh but the whole GameObject. I tried searching online and even uninstalled unity to latest version, well vrtk don't work on the latest. So now i am back to unity 5.6.2, and the problem is still there. It is not just my apps, if i open vrtk example scenes the same problem...

    Vrtk controller objects are destroyed on run.