Forums

  • NavMesh Surface in ARKit Hi there,
    I am trying to dynamically create a navmesh by a script, I have a plane which is created dynamically and it's position is constantly updated. I add the navMeshSurface component and build the navMesh, however it's empty. Looking through it using the NavMeshTriangulations I see the vertices and triangles are 0. The dynamically created object has a plane mesh (mesh filter) and that mesh has real values for vertices and triangles, when this plane mesh is used to generate a navmesh it...

    NavMesh Surface in ARKit
  • ARCore – Lean touch – Move object in X and Z axis (I want to Lock Y axis) Hi,
    I have created object moving app using ARCore. for object move purpose I have used Lean touch it works fine, But I want to lock axis Y it's overlapping my ground plan.
    Please help to solve this issue.
    Thanks in advance.
    Sweetan M
  • Vuforia Android build, split(obb) apk BUG. [SOLVED] Hi Vuforia community. Im find Vuforia split(obb) application bug in Android. Vuforia version 6 and 7. Unity 2017.x.x. Repro steps: 1. Added Databases in VuforiaConfiguration. 2. Make Android build without split application option - Work Fine. 3. Enabl...
  • Switching Multiple Scenes With Single AR Camera Hi Guys,

    This particular topic has been discussed in a few other threads but I haven't come across a conclusive answer. I am trying to prototype an app to switch between multiple AR scenes using the same image target and a simple UI/buttons. Fairly easy to implement using the SceneManager class but problem comes when the AR camera is destroyed and a new one is created from the new scene causing a brief blackout & delay.

    To avoid this I have attached a simple DontDestroyOnLoad script to...

    Switching Multiple Scenes With Single AR Camera
  • Submitting ARKit apps to AppStore without Face Tracking The current latest version of the Unity ARKit plugin includes some native calls to Face Tracking Configuration that will trigger an App Review failure on non-Face Tracking apps because they use TruDepth API without providing a privacy policy.

    We're in the process of fixing this problem for the latest plugin code, but in the meantime, you have two options for submitting your app:

    1. You can submit your apps with an older version of the plugin that does not contain the face-tracking code:...

    Submitting ARKit apps to AppStore without Face Tracking
  • Vuforia registration issue I'm trying to create an account with Vuforia. But when I click create, it gives me a "System Error" pop up.

    I have filled in the details as required. I have refreshed the captcha multiple times, I am not entering any
    strange characters or funny looking email addresses.

    I have also tried different web browsers with ablocking disabled.

    Anyone else having this problem?
  • Vuforia Ground plane Entire Picture Hello!! 1- What is the life cycle of Vuforia ground plane. 2- How tracker start tracking .. ? 3- Any event when new plane is detected ..? or how its detected ..? 4- Is its necessary to keep looking for new planes when you have found one ..? 5- If ...
  • Failed to get rendering parameters for main camera on HoloLens Enabled shared depth buffer for HoloLens and getting this issue. 2017.3.0p4 Bug Report 995002 -Create a new project. -Switch build platform to Windows Universal. -Go to the player settings and enable XR and add the Windows Mixed Reality SDK -Switch ...
  • ARCore Drag (Move,Rotate, Scale) Move is not working Hi,
    I have created a product showcase using ARCore. I used (lean touch and TPD) for Drag (Move, Rotate, Scale),
    While I used Lean touch That time Drag (Move) it's not working.
    Note: When I touch the camera that time camera prefab is missing while I used in Lean touch.
    When I used TPD That time Drag (Move, Rotate, Scale) it's not working.
    Can you please help me to solve my problems.
    Thanks in advance.
  • Controller Inputs with Daydream Controller Hi there,

    Relatively new to Unity so am after a little help regarding the Daydream Controller Inputs.

    My aim is to reset the scene by pressing the app button on the Daydream Controller. I'm guessing I need to have the Gvr Event System component in the scene? Where do the scripts relating to the button presses go?

    Thanks, all
  • SD53 S
  • Make vuforia videoplayer match the height of the image target Here's my scenario:

    I have an image target with size 1000 and height 667, and a video with resolution 1920 * 1080. For transparency the video is made twice as high and includes alpha channel values in the bottom half which is applied to the video by a shader.

    I have copied the videoplayer sample from the core samples, and have it load the videofile and apply the shader at runtime.

    My image targets scale is divided by 10, and therefor looks like this in the inspector:...

    Make vuforia videoplayer match the height of the image target
  • “Start Remote ARKit Session” does nothing Hi,
    I've had all my projects connecting fine to the ARKit Remote with version 1 of the Unity ARKit Plugin , but am trying to get V1.5 working and clicking the "Start Remote ARKit Session" button does nothing.
    I've followed all the steps, tried loading the latest BitBucket code as a separate solution, set it as a development build, and used the tutorial scenes and still nothing. I'm using 2017.3.1 unity build.
    Anyone else having this problem?! heelp! :)
    Thanks
  • AR core AR core position transform is not working.how to solve this problem
  • Model target can’t display guide view 2D Hi
    As title mentioned about, when i export official sample apk,it runs good on my andriod phone,the guide view 2d can dislplay whether i use custom image or not,like followed shot image. View attachment 275291
    but when i use custom database,it can't display Guide view image,i already add a license key,so i don't know deal with this situation.
    thanks