Forums

  • What is the difference between ARAnchor and ARUserAnchor? Hi! I was reading the Unity AR Kit Plugin Documentation and the Github Depository, and wanted to clarify the difference between an AR Anchor class and a AR User Anchor? Thanks!
  • Bizarre Camera artifact, two “snackbars”, no live camera Okay but I can't seem to get ARCore running correctly. I've tried it on several different versions of unity. 2017.3, 2017.4 and 2018 beta 10. On all of them I get this:


    it shows the point clouds and leaves residual color wherever a point was. It clearly shows mirror images of the point clouds. It also shows at least two "snackbars" and the multiple point clouds are oriented towards their respective...

    Bizarre Camera artifact, two "snackbars", no live camera
  • ARCore HelloWorld : Simple One Touch Gameobject Active Hello,
    I runs demo app of AR Core Hello World with tracking area. Its worked good but user's when multiple clicks, its shows multiple Andy (Android) simultaneously. Now, I want to know "how can i stop multiple touches in my app ?" that's my queries. I want to show one click for one Andy (Android) game object. I hope for best solution for my query.

    Please find out on below screenshot.


    Thanks for Advance...........!!!!!
    View attachment 273223
  • How to solve each two collider game object “OntriggerEnter” Collider problem ? Hello,

    I creating AR Runner Game app using AR Core. Its worked properly, but user's can't able to access (camera to cube) game object collider OnTriggerEnter() funtion won't working properly ? So, now I want to know "How to solve each two collider game object "OntriggerEnter" Collider problem ?" that's my queries. I want to trigger AR Camera to another box collider function. I would like to create similar AR Runner Game. I hope for best solution for my query.

    I attached on...

    How to solve each two collider game object "OntriggerEnter" Collider problem ?
  • TrackedPoseDriver issues I am making some tests with ARCore and i notice there is a TrackedPoseDriver component attached to the main camera. This component keeps track of the device orientation ( rotation and position ). Rotation works fine but position is a mess. When i shake...
  • Reset ARKit App I have a Reset button to reset the entire scene (using SceneManager.LoadScene(0)) but the plane anchors persist. How do I make sure they are removed? I want it to be exactly as if I restarted the app.
  • Unity ARKit Plugin FAQ Posting a FAQ in the hopes that people do not repost the same questions over and over again. Please look through this, and if possible, through the forums before you ask your questions! Unity ARKit Plugin FAQ Q: What is the Unity ARkit Plugin? A: U...
  • Old gvr project crashes on android (worked in 5.5, crashes on 2017.4 build) Just posting here for future googlers.. Tested upgrading old 5.5 cardboard vr project into 2017.4.0f1 LTS, and all went fine, except that Android build crashes on start, with the error below: (iOS build works fine, and that error is probably caused b...
  • Keeping GvrReticlePointer when you switch between cameras or scenes? Hi All,

    I have scoured the internet with no luck so far so I hope someone can help.

    I have 2 camera's in one scene that I would like to go back and forth depending on what button was clicked. This is for the main menu. So when I click Sound Options button in my canvas, it takes me to another camera that shows the Sound Settings canvas. That already theoretically works but the problem is the reticle not in the next camera or another scene completely.

    I have no idea how the hierarchy should...

    Keeping GvrReticlePointer when you switch between cameras or scenes?
  • ARCore1.0 Sample Scene Error: “does not implement interface member” Hi All,

    I am experimenting with the newly released ARCore 1.0 for Unity with the 2018.1.08 beta. However, I have a console error I can not seem to fix. As a result, unable to build the sample scene.

    --- Error Message ---
    Assets/GoogleARCore/SDK/Scripts/Editor/BuildHelper.cs(34,18): error CS0535: `GoogleARCoreInternal.BuildHelper' does not implement interface member `UnityEditor.Build.IPreprocessBuild.OnPreprocessBuild(UnityEditor.Build.Reporting.BuildReport)'

    --- Attempted...

    ARCore1.0 Sample Scene Error: "does not implement interface member"
  • ARKit 1.5 backward compatibility with devices that don’t have 11.3 I'm successfully building and using ARKit 1.5 apps with the ARKit unity plugin spring 2018 update branch on a device that I've updated to the iOS 11.3 beta. On a device with 11.2, though, the ARKit scene crashes on load.

    How can I make the app backward compatible so iOS 11.2 devices can still use ARKit with the horizontal planes and 11.3 devices can use the vertical planes?
  • How do I pause Plane Detection after finding a Plane? Hi, after I have found a plane I want to manually pause the detection so the plane does not keep changing. How can I do this? Edit: Basically I want to change Plane Detection to "None", then be able to change it back to Horizontal+Vertical w...
  • Post image effect with Single-Pass Stereo Rendering on GearVR Hi all,
    I'm trying to use posto processing with Single-Pass Stereo Rendering on GearVR and DayDream.
    Now using Windows 10 + Unity 2017.2. My mobile device is a Samsung S6.
    My post effect consists of two steps:
    RenderWithShader renders the scene with my very-simple shader that draws everything is visible with White color
    Blit operations to perform more complex operations.
    Now I'm trying to make work the RenderWithShader operation. First of all: is it allowed to use RenderWithShader with...

    Post image effect with Single-Pass Stereo Rendering on GearVR
  • Object does not show Hi,

    When I replace the Andy object with a cube to test it works. The I tested 2 cubes, larger in size, in an empty gameobject as prefab and it worked. But when I added a player and a path (empty game objects connected via a script) for the player to follow, all in one empty gameobject made a prefab out of it and this doesn't show on the plane when I tap the screen.

    I went back to the previous prefab with the 2 larger cubes and that doesn't work either anymore. Only one single cube works...

    Object does not show
  • Google ARCore and VR combined? I was wondering if it would be possible at some point to combine ARCore and Google VR in one app? This way you can use ARCore for position tracking and VR for immersive applications. This would be a perfect situation for both technologies combining the...