Forums

  • Switching from Vuforia AR to VR – Camera Freeze Hey there,

    we have some issue with the AR Camera in Vuforia after switching to VR Mode but only on our Android Build. In the iOS Build everything works fine.

    What we did: We implemented the AR/VR Transition from the Vuforia Examples into our project. Transition and switching the components works fine, but from time to time the camera position freezes without any obvious reason.
    After building the same project on an iOS Device everything works like intended.
    At this point we haven't...

    Switching from Vuforia AR to VR - Camera Freeze
  • Limitations of using AR in tablets/Mobile devices? Hello all, I want to track large outdoor spaces like basketball court etc. Is it possible that my tablet or mobile device will be able to track the poles, bushes, nets etc.? Since I have seen AR used only in indoor and small spaces, I would like to kn...
  • Oculus Go Store – Beta testing of the app Hi everyone!
    I have uploaded my app to alpha and beta channels for Oculus Go. Then I added another account as "Developer" role. Then I run my Oculus go linked to Developer account, switch to "developer" home view. After that I see the application, but it is not available.
    It said me this message like this : "This app is not availbe for install. It's available only for testers and developers!"
    But I use developer account!!!
    How to make beta test, like TestFlight on ios, but for Oculus Go....

    Oculus Go Store - Beta testing of the app
  • Stop Oculus headtracking on 2nd camera Hey guys, I am using a second camera to render on top of the main camera which I am going to use for UI and such. The second camera is parented to the main camera (so that it follows your head). The problem is that both cameras are still moving relati...
  • Trees flickering like mad in VR Hello, Sorry if i ask silly question, im fairly new to VR, so i made a nice scene sort of like a forest with a bunch of trees. When i play it in regular (non VR) is looks really nice, when i build it for VR it looks really bad, the trees flickering li...
  • Hololens dll not found exception I have a windows dll that I can load without problem in a unity UWP app (laptop and surface pro4). When I try to load this dll in a hololens application, I have a DllNotFound exception. After investigating, I have found several issues : - the dll has a...
  • Correct camera rotation (Oculus Rift) I was trying different approaches to use the second Xbox controller stick to implement camera rotation with the Oculus Rift. To do this I'm rotating the parent game object of the camera. However I was not getting a a fine result. It seems that the transform of the parent object and the camera get out of sync after a while. The camera scripts in the asset store seem to suffer by the same problem...

    This was my last approach:
    Code (CSharp):
    1.         void Update () {
    2.             // rotation by...
    Correct camera rotation (Oculus Rift)
  • How to render a SurfaceTexture to a Unity texture I've been trying a few different approaches to get the texture images from an android SurfaceTexture to show in a Unity texture. I'm building on an Oculus Go.

    Here's my list of different approaches:
    GPU:
    1. Display external texture from surfacetexture directly via `Texture2D.CreateExternalTexture`
    1. Creating the surfacetexture via issuepluginevent but the rawimage with this texture attached just looks like a weird button sprite.
    2. Draw surface texture -> framebuffer object -> unity...

    How to render a SurfaceTexture to a Unity texture
  • Unity Teleporter for Oculus Go Hi, im trying to add a teleporter to my scene for the oculus go,

    is there a good tutorial for this or an asset I can download that will work,

    id found a great tutorial but got lost when it told me to add a gaze pointer prefab, I couldn't find one anywhere in the oculus integration assets?

    ive tried many different tutorials now, and downloaded a few different assets,

    I now nothing about scripting yet, I just want to be able to move around in my scene please

    thanks, andy
  • no display in Oculus rift with AMD Firepro W7000 graphic card hi I,m having Dell Precision T7500 workstation with Xeon Processor, 52 GB RAM and AMD Firepro W7000 graphic card. I'm using DP to HDMI connector for the oculus.
    The problem is that when i test my scene I m able to see display in only right lence that to only white line.
    All i need to know is that does AMD Firepro W7000 is supported by Oculus or not
  • click to move (VR , Oculus Go) View attachment 372031 I am new to unity and not developer , am an architect i have made a vr app for Oculus Go with teleporting method , but i need to make the camera move forward with the controller press(fire) how can i do that ? attached...
  • Need help with making a radial image fill when looking at it in VR/Oculus Go Hi all! Im very inexperienced with Unity and VR and have almost no experience scripting, but Im getting the hang of it quickly I think. Im trying to have an image fill while looking at it, in the long run Id like it to fill and act as a button that...
  • Judder while viewing 3D objects/models on a Vive Focus There appears to be a significant judder when I pan my head from side to side if I try to attempt anything of significant complexity within my scene. The problem exists even if the only thing in the scene is one, single object. About the only thing that doesn't cause a judder is a simple, unanimated stock Unity model (sphere, cube, etc.). If I animate a model/object the problem becomes much worse. If I try to view a more complex model the problem becomes worse.

    Using the profiler I see...

    Judder while viewing 3D objects/models on a Vive Focus
  • MRTK Hololens Tooltip Problem Hi everyone,

    first of all I'm pretty much a complete beginner in unity and vr/xr development so I hope I can find some help here.
    I am on a very simple project for the hololens and for that I use the mixed reality toolkit.
    So my problem: I have six cubes arranged in a sphere object collection (from the mrtk).
    So when I add tooltips (the tooltipspawner of the mrtk) directly to the cubes the tooltips are completely distorted.
    When I add the tooltips outside of the object collection the...

    MRTK Hololens Tooltip Problem
  • Arkit and armv7 Hi:
    I have been working in an AR feature for my already released game. I have manage to get it working, but now when I try to Archive the product in XCode it gives me a link error like in here:

    https://forum.unity.com/threads/lin...-ios-all-latest-versions.543935/#post-3588187

    What I found this thread was useful as allowed me to continue developing for a while, but I need to release a build for armv7. This build won't have the AR features in as they are not...

    Arkit and armv7