• Bindings for main.exe was not set. But bindings_vive_controller.json exists???? I have steamVR1.1.4 runtime and steamVR2.0.1 plugin. I have tried runing Window>Steamvr input and creating bindings. I see all .json files in project base directory are there. When i start game I see ERR message that bindings are not set. There ...
  • Bindings for main.exe was not set! Even after adding bindings_vive_controller.json? I have steamVR1.1.4 runtime and steamVR2.0.1 plugin. I have created controller bindings via: `Window>Steamvr input`. I see all .json files in project base directory are there just fine. When i start game it is immediately paused because SteamVR ...
  • TextMesh cannot show the text immediately when updating text Hello everyone.
    I got an error, and I don't know how to fix it. The error is that the text of the TextMesh cannot update immediately when I update that text in the code. But when I use Debug.Log I see the text is changed but it does not show immediately, when I change it to other value, it shows the previous text that I changed.
    Here is the sample code I got that errors.

    Code (CSharp):
    1.  public void OnNewSearchResult(TargetFinder.TargetSearchResult targetSearchResult)
    2.     {...
    TextMesh cannot show the text immediately when updating text
  • AssetBundles and Vuforia to load 3D models Hi,
    I'm having problems making an AR app using Vuforia and AssetBundles.
    I want load my 3D models from an external server (dropbox in my case). I follow the steps of this link:
    Everything works fine when I add the script include in the link to my "image target". The problem is when I create a second "image target" and I also add to this target the script with another url that downloads a...

    AssetBundles and Vuforia to load 3D models
  • Stick objects when camera cover up I have an app created with unity 2017.4.6f1 and using arcore v1.6. I placed some object to scene by static coordinate (coordinates don`t changing). When user cover up camera by chance or camera located near some objects (wall, table etc.) - i get &quo...
  • Downloading files to Oculus Go doesn’t work? I'm using these two scripts to handle downloading a file to PersistentDataPath. All works fine in Unity play mode and on the Rift.

    Code (CSharp):
    1.     public IEnumerator DownloadVideo()
    2.     {
    3.         downloadError = false;
    4.         downloadAborted = false;
    5.         uwr = new UnityWebRequest(videoURL, UnityWebRequest.kHttpVerbGET);
    6.         filePath = Application.persistentDataPath + "/Videos/" + videoTitle + ".mp4";
    7.         print("Downloading: " + filePath);
    8.         uwr.downloadHandler = new...
    Downloading files to Oculus Go doesn't work?
  • [Tutorial] How to Use Machine Learning to Show Predictions in Augmented Reality Hey all, we've just released a great new tutorial that looks at how to use Unity and Machine Learning to show predictions in AR - check it out here:

    Hope you find it useful!
  • Windows Mixed Reality losing position tracking around people Hi guy, I need help. I created a win MR app, works fine if only 1 or 2 people around me, if more than 3 people, the headset lost high position, and drop to the floor position, the controllers stop working too, restart app not help, have to restart the...
  • моделинг рук To model the sleeves, with the dynamics of raising hands in accordance with the available video materials. Texture the fabric of the sleeves according to the materials provided. To work out the animation of the movement of the fabric, the final - photo...
  • Tracking Two Faces with ARKit Wondering if it's possible with the current plugin to recognize and track geometry onto two faces? Has anyone here had success with this?
  • Keyboard Input Hello i have a question regarding the keyboard input using Input.GetKey(KeyCode.K) does this current scripting interface work for Mixed Reality? when i run my application i can only see it registers my keyboard inputs when I'm inside the unity Game window. However when i am running it through my simulator i can not see any of my inputs from the keyboard working.

    This question has also been asked earlier but was not answered:...

    Keyboard Input
  • What to do when the camera access is denied? Hi, I just realized there doesn't seem to exist any API to invoke the camera access dialogue in case the user rejects it the first time it appears.

    Once the user rejects the camera access, the session fires a "ARSessionFailedEvent" with the string "Camera access not authorized". However, this string seems to be localized which means you can't even rely on it to know if the user rejected camera access because the string will be different in another language.

    All the examples I've seen don't...

    What to do when the camera access is denied?
  • AR touch input Hi and good day I am currently getting the idea of is it possible to use sphere collider on Augmented Reality object if I want to touch specified hole ( a model with many hole) and it will produce output on the model such as it move item from one ho...
  • Vuforia, NSubstitute and Assembly Definition files Hy, is it possible to acces things like Vuforia (Unity internal) and NSubstitute (added via NuGet) with Assembly Definition files in Unity 2018.2.17? I tried for a few hours to add them, but e.g. when I build for Linux standalone Unity always complains, that Vuforia reference is missing. the same goes for NSubstitute, which is located under packages, but can't be referenced, as I can't access it via project window.


    Best regards :)
  • Why are mobile applications not working in CHINA?Any option for the app to work without using VPN? Recently I gave build to a client to test an app.I did it using Unity and ARKit. I took a IOS build. From the clients feedback he downloaded the application but the app is not initializing. For the app to initialize it requires Internet connection. I used a Plugin in my app when I contacted them they told me that they are using Google's Firebase in their backend. Is this the reason that the app has been blocked or any other issues. How to find out?.Client cannot use VPN.Any solutions?