Forums

  • Black pixels when masking with depthmask shader in Android I cannot seems to figure this out. I get these awful black pixels showing up where objects are supposed to be masked by the depthmask shader/material. It only happens on Android devices, and does not happen in editor or iOS. I found in some other forums and threads to try to set ZTest to Always in the shader, and that just made the depthmask not work at all, it didn't mask anything.

    Anyone else seeing this or have any ideas?

    I'm using Unity 2017.3.1f1 and the Vuforia that comes with it....

    Black pixels when masking with depthmask shader in Android
  • Child camera rotates faster than parent camera My setup (Unity 2017.3.1f1): - Main camera (can see everything but the UI layer): click - Child camera (can only see the UI layer): click - Canvas (uses the child camera as its render camera): click When I rotate my WMR headset, the child camera rotat...
  • OpenVR/None: “HmdNotFound” error without HMD My app uses VR SDKs (Project Settings - Player) in this order:
    - Open VR
    - None

    If I unplug the headset (Lenovo Explorer) and start the app, Unity (2017.3.1f1) prints an error message:
    Isn't the "None" SDK supposed to become active if there's no headset connected, so you can use your app with or without an HMD? I'm not trying to get tracking to work without the...

    OpenVR/None: "HmdNotFound" error without HMD
  • Once creating oculus go build, .apk file is not getting generated. Unity Version 2018.3.2f1
    Oculus Integration package Version (Latest Available on Asset store)

    Amusing OVRCameraRig as Player camera. Selected XR supported and added Oculus to the list. Given a proper package name company name in other settings. and start packaging. it's showing as Building Player, Compiling Shader's variants but at the end .apk file is not getting generated.
  • Markerless AR Hi,

    I'm working on an app that uses markerless AR. I have playing cards that when detected by the device display a 3d object. In the past I've used ARToolKit for this, but I think that's been shut down.

    Can someone recommend a solution?

    I don't need to upload images to a remote server, the images are a fixed amount. Vuforia seems way too expensive and does far more than I need for this project. The same for Wikitude. I'm thinking of using OpenCV and this example ->...

    Markerless AR
  • Random object placements in space Hi all,
    I'm trying to create a Pokemon Go like experience, and wondered how did they placed Pokemon in space randomly and kept them in place. My game is working on picking spells from markers, and as of now I have an enemy spawning marker. I want not to use the spawning marker, and have enemies randomly appearing in space.

    We tried various solutions but the camera POV gets messed up.

    Any solutions or ideas?
  • [Solved] VRTK – Interacting with Object While Moving Issue Hi everyone,

    I am not sure if this is a bug with VRTK or just a general bug. I am new to Unity so I really appreciate any help. Thanks!

    I will try to explain below what is happening but take a look at the video to get a better idea

    When the car is not moving, putting my VR controller on the steering wheel will highlight it red (showing that it can then be interacted with) and I can grab/move it.

    But when the car is moving, the steering wheel doesn't highlight when I place my controller...

    VRTK - Interacting with Object While Moving Issue
  • Custom Machine Build Hello. I have been tasked with building a machine to run a Unity experience that would consists of four 3840x2160@60Hz outputs simultaneously and stitching together a single "world" with a net resolution of 14,000x2160@60Hz. Outputs would hav...
  • Google Cloud Platform – Google Maps SDK Hello Everyone, I am a computer science student and I am working on an Augmented Reality app project dealing with geolocating and georeferencing objects in AR (very much like “Jurrasic World Alive” and “Pokemon Go”). I was going to develop it using th...
  • Enable/Disable SteamVR on focus gain/loss Hi @ all, to be able to run multiple instances of a VR game (for networking), I want to enable VR on window focus and disable it on focus loss. In Player Settings > XR, I disable VR support. In a script, I call the following Update()-Method to enab...
  • Cannot connect to Hololens in Unity Using Unity: 2018.3.2f Want to connect hololens with project, but i cant because: Holographic library PerceptionRemotingPlugin: Failed to lead dll UnityEditor.PopupCallbackInfor:SetEnumValueDelegate(Object, String, int32) When i click on Connect in ...
  • Downloading prefab and assigning at run-time in AR-Core I want to make an application, in which the prefab are stored in the cloud, at time of using only we need to download that particular mesh(prefab) and apply to the AR-Core project. In addition to make the app size smaller without/with the help of .obb...
  • Enabling/disabling VR with SteamVR 2.0.1 Hello,
    as the title says, I'm trying to enable/disable VR between different applications, and I need to do it as many times as I want.

    Using https://forum.unity.com/threads/enable-disable-steamvr-on-focus-gain-loss.510914/ will work, but since SteamVR got updated with Actions and Poses etc., I got nasty exceptions since these things don't seem to be handled correctly after disabling VR.
    I also tried to disable all actions before disabling, but when I want to come back and...

    Enabling/disabling VR with SteamVR 2.0.1
  • Disabling VR in a specific scene (Oculus DK2) [SOLVED] Hi all,

    I'm wondering if anyone knows if it's possible to disable VR in a specific scene?

    What I have is an initial character creation scene (made up of UI elements), in which I want to use a static camera that the player completes on their monitor (It's a personal thing about not really liking UI's in VR). Once the character creation is completed there is another scene which tells the player to put on their headset and press a button on their controller, it then loads in the main...

    Disabling VR in a specific scene (Oculus DK2)
  • CallBack to a Native Plugin – Can’t Play more than one. Hello community !

    I'm a french Engineer working with Unity for Augmented Reality problematics.

    I'm displaying a background Image in a RawTexture UI in my Unity Scene with a Callback to my Native Plugin. For this, I'm using m_texture.GetnativeTexturePtr() to get the pointer on my texture and I give this pointer to my Plugin. My plugin set values to this.

    All work well. Just one problem : I can play for debugging one but no more than one.

    I'm stopping my plugin, variables..etc... but...

    CallBack to a Native Plugin - Can't Play more than one.