Forums

  • Get real world device rotation Hi everyone,

    I would like to get the real world rotation of a device, but I don't clearly know how to achieve that. I'm trying to use the gyroscope attitude function, but it doesn't work for me.

    I only want the x and y rotation (in Euler angles) values, so if I move the head in a horizontal way, the y rotation angle is moving, and if I move the head verticaly, the x rotation angle moves. The z angle doesn't really matter, it will always be 0. But I want it to be in the real world rotation,...

    Get real world device rotation
  • Dreamglasses and Vuforia ? anyone? Hi!! Is that possible to use the Vuforia Unity Extension on Dreamglasses? Is there an optimal configuration that works well? Have anyone tried? Thank you!
  • Steam VR Sliders Hey guys

    I'm trying to figure out how to implement a slider with Steam VR and basic Unity UI. I had hoped it would just work if I put an Steam Interactable Component and a Steam UI Element Component to the slider. I receive a hover color change but cannot click and grab the knob. I've tried also linear drivers to no avail. Has anyone in these threads ever created a Steam VR slider? I would really appreciate the help.

    Thanks in advance
  • Creating games for VR and non-VR users alike Hey gang. I'm working on a project that targets Oculus, Vive (through OpenVR), as well as keyboard & mouse/gamepad folks who have no headset. I'm using Unity 2018.3 and the built in XR 'virtual reality supported' features.

    Building a project that switches between these camera and control schemes seems straightforward enough; but Unity seems to run into some errors on machines that don't have any VR software/drivers.

    I get these warnings/error in Editor (on a mac with no VR)...

    Creating games for VR and non-VR users alike
  • Vuforia AR Camera getting blurry Hey, I am developing an AR App with CloudReco and noticed a strange behavior. When my app starts it starts with the AR Scene and everything works as expected, See Screenshot1. View attachment 355315 When i am leaving the scene (loading a norm...
  • SteamVR Input Generation stuck on assigning default actions to monobehaviours after I hit save and generate it goes threw the generating steamVR Input but always gets stuck on Assigning default actions to monobehaviours...
  • Need some guidance on using Interactive 360 sample project Hi where can I find some document or tutorial for using Interactive 360 Example asset available here - https://assetstore.unity.com/packag...rojects/interactive-360-sample-project-108974 I want create something similar for my current project.
  • Question: What software would you like to see in VR space? I am part of a team of grad students and we're looking to develop VR software for free. What software do you want to see in the VR space that doesn't already exist?
  • why is my non VR camera working for my htc HMD when I hit play? figured out when in the player settings VR support is enabled all cameras can render HMD's. How do I go about using Steam Camera rig prefabs. Should I use the prefab for the camera that steam uses or add all the crap to my main camera in my game. just confusing what rout to go about after I have imported the steamVR asset store package and trying to figure out wtf to use lol.
  • SteamVR Moving in the Direction the Player is Looking Hello, we are trying to develop a VR game using the HTC Vive. We want the player to move in the direction in which they are looking when the touch-pad is pressed, but instead we move in the same direction no matter which way the player is looking. Here...
  • Error when compiling program Hello. I have an error when compiling program.

    D:\AR3DObjectsAndShadows\Temp\StagingArea\AndroidManifest-main.xml:3:3-72 Error:
    uses-sdk:minSdkVersion 14 cannot be smaller than version 16 declared in library D:\AR3DObjectsAndShadows\Temp\StagingArea\android-libraries\gvr\AndroidManifest.xml as the library might be using APIs not available in 14
    Suggestion: use a compatible library with a minSdk of at most 14,
    or increase this project's minSdk version to at least 16,...

    Error when compiling program
  • Camera Disable in Vuforia in Unity I created an AR camera in Unity But It is unable to make the camera visible
    View attachment 354439
    It looks like this, whereas it should be able to show the screen
    I already add the key license key in the Vuforia Configuration and add the database card downloaded from the internet. Don't know what to do and please help.
  • Vuforia databases – Image Target issue Good day! Have some problem about importing vuforia target database to unity. Import is ok, i see in Vuforia configuration two databases: My imported database and VuforiaMars_Images database, but when i create image target, it appears as empty rectangle without default image in the scene and on inspector i see for item "Image Target Behaviour (Script)" next settings

    Type "Predefined"
    Database "EMPTY"
    Image Target "EMPTY"

    When i click on EMPTY for database, in dropdown i didn't see...

    Vuforia databases - Image Target issue
  • Object moves after image Tracking Found Hey Guys I am facing this issue : After placing an object over an image, the Object moves with the camera and not staying over the Image, How can we Fix this Issue? remark: ground detection and Device Track Pose is Enabled with optimization for image...
  • SteamVR 2.0 modified teleport point Hello all,
    I'm new to VR development in Unity, in fact didn't get a HTC Vive headset, yet (next week if all works out). I have been viewing a lot of tutorials on Youtube and Pluralsight on setting up SteamVR + Vive in Uinity and have a solid understanding how to set that all up, with pickups and teleporting. For my app, I want the user to not only be able to teleport around a room (several room locations in a house, all loaded in same scene, no plan to loadScenes/Levels). The...

    SteamVR 2.0 modified teleport point