• HoloLens and Vuforia – which Unity version? is it actually possible to get the HoloLens working with Vuforia at the moment?

    i've run into multiple SDK issues. it would seem that vuforia needs the 10.0.16299.0 SDK but the HoloLens refuses to build on anything newer than 10.05.15063.0 SDK.

    if you are having success building HoloLens combined with Vurofia apps, what version are you running? or is this just an SDK problem we'll have to await a fix for in a newer version of unity?

  • Drift issue in ar/vr app I'm having trouble finding much info on fixes on this. We are currently developing an app that will include an AR+VR portion where you will be able to switch between the two based on certain actions.

    We ran through Vuforia's AR+VR example and have the switching working, however...

    When switching to VR we sometimes experience an issue where the scene seems to rotate or spin. A bit of research suggest it's usually referred to as "drift" and seems to be a common problem in VR.

    Using runtime...

    Drift issue in ar/vr app
  • Blade Runner Revelations (Google Daydream VR)
  • UWP command line arguments Hello,

    I am wondering if there is a way to modify the generated project when building a UWP app to:
    -call it easily through command line
    -pass custom arguments that can be used in the default loaded scene (i.e. set the text of a UI element to be the first argument)

    I 've managed to call my app through the CMD with an Alias, but I cannot parse any extra arguments after that and pass then to Unity. I 'm using Environment.GetCommandLineArgs(); in my scene, but I don't think that is the...

    UWP command line arguments
  • AR based navigation hello,i want to develop an AR based navigation application for android devices.since i am new to this field(AR),i dont have any idea where and how to start with please help me on that ASAP. thanks in advance
  • ARKIT Face scripts + scene example broken/crashes on IOS 11.4 Hey I'm trying to test the sloth face example or face mesh example scene doesn't open or goes to black on ios 11.4 curious if anyone else is having trouble with this?

    I isolated the problem to the script below and it opens normally with the unity logo then crashes or goes to black screen

    I tried using the 12 beta and it still has problems
    UnityARFaceMeshManager is the script isolated the problem too

    I'm using 2018 and IOS 11.4 + 12 and Xcode 9.4 and tried the beta xcode 3...

    ARKIT Face scripts + scene example broken/crashes on IOS 11.4
  • Gear VR Testing? I don't know if this as been answer yet but if it has I apologize for my ignorance but I have tried to search for this answer and I have not found anyone asking this question.
    Can I do a Samsung Gear VR build test on a smart phone that is not a Samsung Note4? For example can I make build and test it on a Samsung Galaxy S5?
  • can’t build – error CS0719 about NetworkInterface hi everyone, i'm trying to uwp build project.
    but i can't build because error code - CS0719 : 'NetworkInterface' : array elements cannot be of static type
    how do i fix this error?
    in my code :
    Code (CSharp):
    1.     NetworkInterface nics;
    2.     string MacLicence = "TestMacAddress";
    3.     bool CheckAddress()
    4.     {
    5.         bool check = false;
    6.         string macAddress = null;
    7.         foreach (NetworkInterface adapter in nics)
    8.         {
    9.             PhysicalAddress address =...
    can't build - error CS0719 about NetworkInterface
  • Vuforia requires the WSA Capability ‘WebCam’ , ‘Microphone’ , ‘InternetClient’???? I received these messages via console:

    • Vuforia requires the iOS CameraUsageDescription to be set. Please set a camera description in the Player Settings like the following: Camera access required for target detection and tracking
    • Vuforia requires the WSA Capability 'WebCam' to be set. Please set this capability in the Player Settings
    • Vuforia requires the WSA Capability 'Microphone' to be set. Please set this capability in the Player Settings
    • Vuforia requires the WSA...

    Vuforia requires the WSA Capability 'WebCam' , 'Microphone' , 'InternetClient'????
  • Fade works on screen but not in headset Hey all...
    I have VR app that will load one video, fades out loads new video fades back in. This all works fine on the monitor. However, in my Oculus headset this is not working. I've tested wondering if it was because of the placement of the panel but, but no matter which direction the headset is pointing, the screen fades, but the headset does mot.

    The fade is based on modifying the alpha of a UI panel.

    Any suggestions on how to correct this?

    Thanks so much!
  • (bug report) ARM64 breaks VR for Gear VR Didn't see a board for ARM64 (experimental) build target.

    Unity 2017.1.7
    .NET 4
    XR enabled
    simple scene
    Galaxy Note5 Gear VR device

    What I did:
    Enabled ARM64 target build architecture (for Android)

    What I got:
    Device does not enter VR mode.

    Confirmed that disabling ARM64 and leaving everything else the same resolves issue.
  • Non-VR App with “Toggle VR” button ? Hi everyone !

    I am currently developing a software that reproduces an existing WebVR app which basically consists in a 360 scene viewer.
    The WebVR app has a classic browser view in which we can click and drag to rotate the camera and a "toggle VR" button which enables the view in a MR device if used in Edge.
    In my app I already implemented the basic view, but I can't find a way to create the same kind of "toggle VR" button for MR headsets, is there a way to do so in Unity ? I already have...

    Non-VR App with "Toggle VR" button ?
  • Inaccurate measurments by ruler / measurement app in unity ARKit I'm working on an application for room measurement, a ruler of sorts, using the ARKit in Unity3D. For this I am using raycasts to place objects (spheres), against the wall, and calculate the distance between those objects by getting the position of recognized walls, which the ARKit generates.

    The problems I have:

    • My placed objects are mostly a bit to far away from those ARKit walls.
    • Those objects are floating away when I move. So the measurements are not that precise.
    • Extra...

    Inaccurate measurments by ruler / measurement app in unity ARKit
  • HoloLens shared tap-to-place issues Hello, the problem I'm having is a little complicated as I tried different ways of solving it ending up with different issues, so I'll try to break this down.
    Using Unity 2017.4.1f1.

    1. Mixed Reality Toolkit (Example)
    I implemented this specific package containing the standard toolkit and a few examples, then proceeded to open the SharingTest scene. It had a missing script which I replaced with...

    HoloLens shared tap-to-place issues
  • Spawning Prefabs on free Plane-Position AR Hey Guys, i am new to Unity. I want to create a AR-APP in which it is possible to create prefabs. This worked for me. My problem now is that I want that the prefabs only spawn when the Space on the Plane is free, but the Prefabs are spawning everywher...