Forums

  • Unable to submit an APK file to Play store with com.google.ar.core error Hi all, I compiled my app with vuforia support and tried to upload it to the store. However, I encounter this error. The ARCore dependency minimum version code com.google.ar.core.min_apk_version is missing from the AndroidManifest.xml file although ...
  • Any ideas for a VR navigation package? Hi everyone,

    I'm going to implement a spindle control system, in Unity, for scene navigation in VR (something like that used in Quill).

    Since I'm already doing that, it seems that prototyped other control schemes wouldn't be too much extra work. So, if you have an idea that you wanted to explore but don't have time to script up then let me know - I'm happy to mock it up and, if there are at least a couple of ideas,...

    Any ideas for a VR navigation package?
  • Resonance Audio, possible Skybox issue, or something else moved here as it seems more related: https://forum.unity.com/threads/res...-high-fidelity-spatial-audio-at-scale.503347/
  • Cardboard VR distortion Hi All,

    Running ARCore's sample scenes works perfectly on a phone (Pixel 2). However, upon checking off 'VR Support Enabled' and putting it into a headset, things look wonky.

    Enabling that checkbox does split the camera view into two. ARCore only uses one camera, so it must be duplicating the view. I notice I can get a better image when adjusting the lens on my cardboard headset. I've heard this could be due to ARCore using a different FOV than Cardboard.

    Does anyone have any insights...

    Cardboard VR distortion
  • ‘Virtual buttons’ for non Vuforia AR apps All the examples showing virtual buttons in Ar are using Vuforia's solution. But I am not using Vuforia and need a virtual button solution in AR.


    What is the best solution? Should I import the Vuforia framework just for the button?
  • ARFoundation + ARKitRemote? Hello everybody, Is there a way to get the ARKitRemote to work with the ARFoundation toolkit? I’ve got the remote working with the older examples (including that compression workaround posted here), but I’m not sure if that’s the right way to go with ...
  • Stereoscopic rendering support I've read the manual on How to do Stereoscopic Rendering but for the life of me I cannot figure out how to turn on stereoscopic rendering in Unity. The DirectX sample that is referenced does not use or require any aspect of Unity as far as I could see. I got it to compile and run, but it is a standalone C++ Windows app, not a Unity-based PC app. Also, in my Player Settings, I do not see any checkbox for "Stereoscopic...

    Stereoscopic rendering support
  • Unable to connect Unity and ARKit remote I get the following error. 2018-07-09 20:43:26.641523+0300 remote NSURLConnection finished with error - code -1009 Does any one know how to fix?
  • ARKit Remote workflow issues There are 2 issues slowing me down right now when developing:

    1. There is about a 4 second time lag on the video that hits the editor from the ARKit Remote. It looks like in the demo it's much snappier, but in the comments others are having the same lag issue as I am. Is there any way to troubleshoot this?
    2. I have to select my iphone from the connected player dropdown every single time I press play. I would love it if it...

    ARKit Remote workflow issues
  • ARKit Remote Camera Feed Lag – [FIXED: use USB connection] Hey,

    I've got the latest ARKit plugin installed and working...

    Unity 2017.2.0f3
    Xcode 9.1
    ARKit 1.0.11 (Nov 6)

    ....... with the ARKit Remote built and running on an iPhone SE... but I am getting a lot of lag on the camera feed when running the ARKitScene example.

    I am getting data from the remote and the live camera feed, but its lagging way behind as I move my iPhone.

    I'm just wondering if anyone else had similar performance issues, and if they solved it.

    Cheers
    Richie
  • Which one of these camera has better integration with unity ( Xiaomi Mi sphere Vs. Ricoh Theta V ) Which one of these camera has better integration with unity ( Xiaomi Mi sphere Vs. Ricoh Theta V )
  • Model Target Generator gives a message “Service not available now. Please try again later” Hi, the Model Target Generator application does not open up and gives the message "Service not available now. Please try again later" always. I've spoken to the IT department of the company that I work for and they've asked me if there's a website or something else that needs to be white listed. Please let me know, Thanks!
  • Video capture (3D not 360) for stereoscopic goggles Hi,

    I'm designing an fMRI experiment and I created a virtual environment with Unity3d 2017.3 that I would like to screen to the participants in the scanner using stereoscopic goggles. I'm quite new to C# and Unity, so I figured out that the simplest way for me was to capture videos of this environment, so I can play them later to the participants, (without delays, in a timed manner, using Matlab).
    Given that I use "old-school" stereoscopic goggles (basically two low resolution screens, one...

    Video capture (3D not 360) for stereoscopic goggles
  • VR real time positioning / facing? Hey guys,

    I modelled a room based on a real room so the objects in this room such as the sofa are quite accurately positioned so that in the VR world you can technically 'touch' and feel the objects if that makes sense

    But I have one problem and wanted to ask what I could do to overcome this obstacle if it was possible.

    I have marked the floor so the user must start from that specific position and must face forward at the TV or the VR environment won't match the real environment and...

    VR real time positioning / facing?
  • Default scene in Lightweight Render pipeline with VR displays black screen when built to android Hi There,

    I'm wondering if anyone can help me figure out what I'm missing here.

    The steps to build this weren't a problem. From a "New project" with a lightweight render pipeline + VR setup, all I had to do was ensure the platform was set to android and that I had assigned a bundle identifier.

    I did go ahead and switch to IL2CPP and .NET40 but I don't think those were required steps.

    The problem is that this basic project is ALL BLACK screen when I load to device. I would expect to...

    Default scene in Lightweight Render pipeline with VR displays black screen when built to android