Forums

  • Microsoft Mixed Reality Controller Haptics Hi, Anyone got an example of how to make the hand controller rumble? Thanks
  • How do I make plane tracking invisible? Hello there,

    I want to make blue square invisible? How do I achieve that? I want it to work as it does, just to be invisible to an eye. I've seen apps that do this, but I haven't found a way to do it myself.
  • 360 degree video with Unity ? is it possible? I want to integrate a 360 degree with unity... Can anybody help? please i am new in this field
  • Forward or deferred rendering in VR? to improve overdraw performance. Hello Im working on a tiltbrush created journey in unity for Oculus. Now the app store demands 90 fps throughout the whole app. This is a real challenge for me since I have created a lot of transparent brushes in tiltbrush and it generates a lot of ove...
  • GvrReticlePointer and terrain ray casting Hi,

    I have a problem with ray casting in VR. I have a terrain and I'm trying to implement a point-click-teleport system. I failed to make GvrReticlePointer to work properly, mainly, the reticle keeps flickering and whenever I managed to click, ray casting gives me funny hit points. These are the issues I'm having:
    1. GvrReticlePointer keeps flickering and doesn't work consistently. I understand that it is looking for an interactive gameobjects. I tried few things here:
      • ...

    GvrReticlePointer and terrain ray casting
  • School Boy Avatar: 6-Point Tracking in AR/VR with Inverse Dynamics Created with DeepMotion Avatar: https://deepmotion.com/avatar
  • Compile error vuforia core samples Assets/Common/Scripts/TrackableSettings.cs(22,12): error CS0246: The type or namespace name `FusionProviderType' could not be found. Are you missing an assembly reference?
    This is what my help says about my versions:
    Unity 2018.1.4f1
    Vuforia release notes SDK v7.2.20
    I have everything checked in the download assistant except LINUX Build and MAC Mono so vuforia AR is checked.
    In Build/settings/player setting, I have checked all and still get the same error.
    Thank you
  • ARKit signal SIGABRT Hi, On line 33 of main.mm in thread 1: UIApplicationMain(arfc, argv, nil, ); I get an error: terminating with uncaught exception of type NSException. Anyone know how to proceed? Uploading to i...
  • XR Disabled, Gear VR still intercepts launch Hey hey!
    I've been working on a mobile game recently and played around with the idea of using a VR camera rig.
    And now, I've turned off the VR Supported setting (And also added "None" to the list and floated it top).

    Now I'm trying to disable it and use just a normal camera setup, but my phone with the Gear VR software installed keeps launching Gear VR whenever the app launches.
    I've been at this for the last 24 hours and haven't had any luck.

    Does anyone know what's causing Gear VR to...

    XR Disabled, Gear VR still intercepts launch
  • The VR app for Oculus, with options managed from PC? I would like to create a VR presentation for Oculus. The app will be run on Oculus GO, but I would like to be able to monitor the user progress on PC and also manage its options from PC. Is that prossible and how to start? As a network game?
  • localized and non-localized maps for better tracking results I'm trying to create a scene using ArCore where I instantiate a gameobject when the app starts tracking, and I would like that, after the tracking is lost and resumed, my gameobject remains in the position it was before tracking was lost.

    Positioning my gameobject at the first tracking (using this code: Pose firstpose = m_AllPlanes.CenterPose results in an undesiderable behavior, because probably the first tracked plane isn't so much stable.
    I read in this page:...

    localized and non-localized maps for better tracking results
  • Game hangs if user starts game when SteamVR is running Hi,

    One of our player got an issue that the game hangs (not responding in Windows task manager) if SteamVR is already running, but the game works fine if he starts the game without running SteamVR first.

    We compared the output_log.txt and found that when the game hangs, the log doesn't print this line: "GfxDevice: creating device client; threaded=1". But this line is printed when the game runs normally.

    So I wonder what Unity is doing when when it prints "GfxDevice: creating...

    Game hangs if user starts game when SteamVR is running
  • Vuforia Ground Plane Emulation not working in 7.2.20 Here we go - just updated to Vuforia 7.2.20 and without doing anything and just running our app we get this error everytime in the console. This happens on mac and windows in the Unity 2018.1.0f2 release

    It's pretty annoying too if you are debugging or watching for errors since this plugin seems to have been released without this being picked up on and it also means we actually can't emulate a ground plane in the editor. Makes me wonder why I'm not just using Unity ARFoundation for the...

    Vuforia Ground Plane Emulation not working in 7.2.20
  • How to make a touch and drag ARCore Hi, I'm creating an ARCore app but I want that to be like the gif, touching and draging like the ARStickers, I watched a lot of tutorials but it doesn't work :/ so I decided to do this, does anyone knows how this was done? I'll really appreciate any help. Thank you. View attachment 286057
  • ARKit: Understanding Scale/Positioning Hi all. I have a small question and there has to be an easy solution. Probably I am stuck in the rut... Explanation: I have an object and want to set the Camera to a specific position in the object. This is the method I use to position the camera: ...