Forums

  • How to Drag Slider With Finger I'm making a menu system for my VR game. The menu is sized in worldspace and you pick it up like a clipboard. I'm using an Oculus, but this solution probably doesn't have much reliance on the Oculus SDK. I have the menu set up so that buttons have a trigger box collider on them, and I add a tiny trigger sphere collider to the tip of both index fingers of the Oculus LocalAvatar. Then I use OnTriggerEnter() to add functions to the buttons as I need. This way I can press buttons with my finger....

    How to Drag Slider With Finger
  • Cheap Water and Waterfall for VR How can I create cheap water (calm) and a moving waterfall in VR? Somewhat similar to:
  • How to create a HTC Vive menu with Gaze Hi. I have been searching the web and cant find any good tutorial where to begin to do this. I want to make a game menu for my HTC Vive game. I want to use the Gaze method. How is this done? I cant find anything with HTC vive, only with Google Cardboa...
  • Large videos not playing on Gear VR, but do play on Google Cardboard. Any ideas? Hi all. I have an odd issue that I ran into over the weekend. We have a VR project that uses some 360 video and ambisonic audio. It runs great on an Android device set up for Google Cardboard, but on the same hardware the video won’t play at all whe...
  • ARKitRemote & iPhone Camera Hello,
    I'm using unity (newest version) and an iPhone 7 via usb on macbook.

    I build and run the ARKitRemote on my iPhone and it is waiting for connection. Then I play a scene like UnityARKitScene or FocusSquare in Unity and connect my device via console. I get my camera picture in Unity but my iPhone only shows "waiting for connection" instead the camera picture. I thought that camera picture is shown in unity and on my device. But not on mine. Why is that ? Anyone have got the same problem...

    ARKitRemote & iPhone Camera
  • ARCORE Unity version Hello

    Which unity version is currently supported to develop with ARcore?

    I am getting this error with the newest 2018.2.3f1 version:

    Assets/GoogleARCore/Examples/CloudAnchors/Scripts/CloudAnchorUIController.cs(85,62): error CS0619: `UnityEngine.Network' is obsolete: `The legacy networking system has been removed in Unity 2018.2. Use Unity Multiplayer and NetworkIdentity instead.'

    Thanks
  • Incremental camera lag when using Model Target Hello, I seem to have found a strange behaviour with the Vuforia camera feed when tracking Model Targets. In Android and iOS devices (not replicable in the Editor), every time I re-scan the model there is a noticeable accumulative decrease of FPS in th...
  • Menu button mislabeled in documentation Hey, this probably isn't super critical, but I think I noticed a small bug in the Input for Windows Mixed Reality docs.

    In the docs, this image suggests the menu button is down on the grip:


    However, here it looks like that button is the system "Windows" button, and the menu button is instead between the touchpad and the thumbstick:...

    Menu button mislabeled in documentation
  • Oculus player character for my simulation issue while FPCcamera movement in Unity. I am working on the oculus project, The player character for my simulation in Unity. in which I have firstperson controller, I have created game object of player in which I put FPCamera as a child and character's body.
    Issue: When I attach my oculus camera it detached from the body and with the Oculus headset movement, FPcamera act as a separate view from the body. the body does not rotate and remain static even though FPcamera is moving according to the headset. However it works fine if I...

    Oculus player character for my simulation issue while FPCcamera movement in Unity.
  • Shader property issue with Single Pass Instanced Hi!

    I have a question related to the Single Pass Instanced mode and setting material texture properties.

    I have a property in a shader defined like this:

    _OverlayTex ("Overlay (RGB)", 2D) = "black" {}

    The uniform itself is defined properly as
    UNITY_DECLARE_SCREENSPACE_TEXTURE(_OverlayTex);

    However when going into play mode, I got a console error:
    "Error assigning 2D texture to texarray texture property '_OverlayTex': Dimensions must match"

    It works fine though and if I remove the...

    Shader property issue with Single Pass Instanced
  • OculusRift Controllers like Steam VR home, Rotate 90° Player Hey there, First at all, I m not a programmer so i need help with this. I need to make a controller for rotate the player 90° with a Oculus button control using the Steam VR Plugin, Anybody of you guys could help me with this please!! D: i ll reall...
  • Vector 3 Problem Help I'm new in C # and Unity.
    I have a interesting project in Unity.
    I'm constantly getting errors in 3 Scripts: error CS1061: Type `UnityEngine.Vector3 'does not contain a definition for` RoughlyEqual' and no extension method `RoughlyEqual 'of type `UnityEngine.Vector3 'could be found. Are you missing an assembly reference?
    Where did I make a mistake?

    Please Help me :)
  • ProBuilder? Shaders? I’m new to this and don’t know what to do Hey, so I've made VR app using some ProBuilder form asset store, and unity version 2018.1.7f1. I've tried to build app for android and I had these errors:

    Shader error in 'ProBuilder/Standard Vertex Color': '' : 'UNITY_PASS_FORWARDBASE' already defined at line 34 (on gles)


    Shader error in 'ProBuilder/Standard Vertex Color': '' : 'UNITY_PASS_FORWARDADD' already defined at line 223 (on gles)


    Shader error in 'ProBuilder/Standard Vertex Color': syntax error: unexpected token ';' at line 288...

    ProBuilder? Shaders? I'm new to this and don't know what to do
  • Oculus Go – Deleting file from persistentDataPath when UnityWebRequest aborted I'm trying to delete a file in Go's persistentDataPath directory if the download has been aborted on quitting the application
    I've tried both OnApplicationQuit and OnDestroy methods which work fine in the Unity Editor and it's persistentDataPath. For example

    Code (CSharp):
    1. public void OnDestroy()
    2.     {
    3.     if (FileExists == 0)
    4.         {
    5.             uwr.Abort();
    6.             File.Delete(Application.persistentDataPath + "/" + videoFileName);
    7.          
    8.         }
    9.    }
    But when quitting the...

    Oculus Go - Deleting file from persistentDataPath when UnityWebRequest aborted
  • World Anchors Do not persist correctly between sessions. Using Unity 2017.4, I cannot get persistent anchors to work.

    Following all tutorials and documentations, I am able to save and load world anchors to / from the store.

    However, the technology just doesn't work. As opposed to how this works with say the Hologram app, where those correctly maintain their positions between sessions, days, and even weeks, using the Unity API has yet to produce an object that maintained it's correct world position between two runs.

    The issue is fairly simple,...

    World Anchors Do not persist correctly between sessions.